Crackly audio on Yamaha EZ-300 / Android

Trouble with Synthesia, your keyboard, or adapter? Think you found a bug?
When describing problems, always mention your OS and game version (shown at the bottom of the title screen).

If your keyboard has USB or MIDI ports, there is a tremendously high chance (>99%) it will work with Synthesia. See what you'll need on the keyboards page.
Post Reply
Jojohappy
Posts: 2

Post by Jojohappy »

Hi, I'm new to Synthesia.
I connected my Android phone to my Yamaha EZ-300 with a good-quality one-piece USB 2.0 to USB-C lead. When playing audio through Synthesia, there's an audible crackle through the keyboard speakers on each note. When playing just the keyboard, there's no crackle.
Also tried a 2-piece lead, USB 2.0 connected to USB-C with a USB OTG adapter, same crackle happens.
Any idea how to stop the crackle please?
(Hubby wanted this keyboard model for the light-up keys as he's a total novice.... but if I can't get good audio through Android it's no good for me!) :grimace:

Thanks in advance all!
Phone is a Samsung Note10+5G running Android 12, App version is 10.9.5890
Nicholas
Posts: 13169

Post by Nicholas »

Sorry for the trouble.

If you choose the EZ-300 from the "Music Output" list on the Settings screen, how do you have it configured? You may be hearing doubled-up notes unless you enable the "Prevent 'local' Notes" option there. If you turn that option on, does the extra sound go away when he plays notes himself?
Jojohappy
Posts: 2

Post by Jojohappy »

Thanks for replying - it's definitely a crackle, not a double note. The same crackle happens whether 'Prevent local notes' is enabled or disabled.
When playing the EZ300 keys by hand, there is no crackle - but on all notes played by Synthesia, the crackle is there.
Nicholas
Posts: 13169

Post by Nicholas »

The "double note" I meant was one (from Synthesia) played almost exactly simultaneously with another (from your own finger striking the key). I can't say I've ever heard it produce a crackle before, but it can make all sorts of strange interference pattern sounds.

If "Prevent local notes" didn't work, does it get any better if you turn off "My Notes" on the same screen? Instead of leaving just the note that Synthesia wants to play, turning off "My Notes" will only leave the note that your own finger is playing. That may improve the sound or remove the crackle.
obyvat
Posts: 1

Post by obyvat »

I had the same problem and I SOLVED it by going to settings - music devices - music input, and turning the device volume completely down. The Synthesia software was amplifying and distorting the sound of my external piano, which created a raspy doubling effect.
Post Reply