LoopMIDI ignoring my keyboard's input

Trouble with Synthesia, your keyboard, or adapter? Think you found a bug?
When describing problems, always mention your OS and game version (shown at the bottom of the title screen).

If your keyboard has USB or MIDI ports, there is a tremendously high chance (>99%) it will work with Synthesia. See what you'll need on the keyboards page.
Post Reply
Pianotehead
Posts: 325

Post by Pianotehead »

So this is not exactly something wrong with Synthesia, rather how loopMIDi cooperates with it. I am using it with Pianoteq 8, just as I've always done, my Casio PX-5S as input, and loopMIDI as output. Finally, Pianoteq listens for loopMIDI as MIDI input. I'm using Synthesia in waiting mode.

It works fine, apart from the fact that loopMIDI always sends the velocity of the MIDI file, and NOT the velocity from my input. In the MIDI file I'm using, the velocity is always 96, but obviously that's not always (in fact very seldom) what I want to send to Pianoteq.

I want my own velocity input, from my own fingers. Is there a way to make loopMIDI + Synthesia work that way together? If not, then loopMIDI is useless as an intermediate between Synthesia and a piano VST. No matter how hard or soft I hit the keys, the velocity I'm sending is always the same, in this case 96.
Bavi_H
Posts: 115

Post by Bavi_H »

In Synthesia's Settings, go to the Gameplay page and find the setting called "Note Loudness". You can change this setting between "Match My Input" and "Get Loudness From Song". The default setting is "Get Loudness From Song". Try changing it to "Match My Input".

By the way, loopMIDI has no way of knowing it is being sent messages from a MIDI file. It just sees whatever MIDI messages Synthesia is sending.
Pianotehead
Posts: 325

Post by Pianotehead »

That did the trick, thanks a lot!
Post Reply