How to display only 49 keys?

Trouble with Synthesia, your keyboard, or adapter? Think you found a bug?
When describing problems, always mention your OS and game version (shown at the bottom of the title screen).
  • If your keyboard has USB or MIDI ports, there is a tremendously high chance (>99%) it will work with Synthesia. See what you'll need on the keyboards page.
  • If you have a Logitech webcam and can't get your keyboard/adapter to work, see this post.
Post Reply
Adinol
Posts: 2

Post by Adinol »

Greetings,

I have an iRig Keys OS 49 key keybaord hooked up to my iMac (OS 12.1).

Right now Synthesia displays all 88 keys.

Is there a way to make synthasia display only the 49 keys that are on my keyboard?

Thanks...
Nicholas
Posts: 12962

Post by Nicholas »

If you haven't yet, you can "teach" Synthesia the range of your keyboard from the Settings screen. Choose your iRig from the "Music Input" list there and then play your highest and lowest keys.

After that, anytime you're on the play screen, tap the zoom icon (the magnifying glass at the top-right corner) and choose "My Keyboard". That should make the on-screen view match your own keyboard.
Adinol
Posts: 2

Post by Adinol »

Hello Nicholas,

It doesn't seem to work for me.

I have my 49 key MIDI connected, the note range is properly set from C3 to C7. I've even reset it a few times.

When I go to the Free Play section and select My Keyboard on the magnifying glass, it still shows 88 keys. If I select 25 or 18 key it does change to that selection, but the My Keyboard setting does not seem to see the note range.

If I click on Custom, it also just shows 88 keys.

Thanks...
Nicholas
Posts: 12962

Post by Nicholas »

Do you have any other input devices enabled? Synthesia will union all of the different ranges together, so other input devices can interfere. On touchscreens the "virtual keyboard" counts as a full 88-key device, so you generally have to disable there for the "My Keyboard" view to work. But since you're on a Mac you'd need to have something else enabled, too.

The Custom option from the zoom menu might be a good workaround in the meantime. It stayed at 88 keys because you hadn't changed it to anything else yet. Use the little arrow buttons in the same zoom menu to adjust the scale however you like. After that, Synthesia will remember exactly how your view is set and use it in every song.
Post Reply