Synthesia and Schubert Etude 450 USB

Trouble with Synthesia, your keyboard, or adapter? Think you found a bug?
When describing problems, always mention your OS and game version (shown at the bottom of the title screen).
  • If your keyboard has USB or MIDI ports, there is a tremendously high chance (>99%) it will work with Synthesia. See what you'll need on the keyboards page.
  • If you have a Logitech webcam and can't get your keyboard/adapter to work, see this post.
Post Reply
stepheric
Posts: 4

Post by stepheric »

Hello, I am using Synthesia on PC with a Schubert Etude 450 USB keyboard. When I want to work on the melody and activate the lighting of the keys, the key I have to press lights up (this is normal), and the keyboard plays the note at the same time without my having pressed. Is this normal? When I then press the key on the keyboard, it plays the note (this is normal) a second time, with a higher volume, Synthesia detects it and continues: the keyboard lights up the key corresponding to the 2nd note, it plays the note at the same time and wait for me to play it in my turn, etc ... What bothers me is that each time I hear the same note twice. Is it possible to prevent the keyboard from playing the note automatically when the key lights up? (I would like it to remain silent when the key lights up). In advance, thank you for your answer.

Bonjour, j'utilise Synthesia sur PC avec un clavier Schubert Etude 450 USB. Quand je veux travailler la mélodie et que j'active l'éclairage des touches, la touche sur laquelle je dois appuyer s'allume (c'est normal), et le clavier joue en même temps la note sans que j'aie appuyé. Est-ce normal ? Lorsque j'appuie ensuite sur la touche du clavier, il joue la note (c'est normal) une seconde fois, avec un volume plus élevé, Synthesia la détecte et continue : le clavier éclaire la touche correspondant à la 2ème note, il joue la note en même temps et attend que je la joue à mon tour, etc... Ce qui me dérange, c'est qu'à chaque fois j'entends 2 fois la même note. Est-il possible d'empêcher le clavier de jouer la note automatiquement lorsque la touche s'allume ? (j'aimerais qu'il reste silencieux au moment où la touche s'allume). Merci par avance pour votre réponse.
icuurd12b42
Posts: 45

Post by icuurd12b42 »

If I understand the settings, I think the option you are looking for is in Settings/Music Devices/Music Output
synthout.png
synthout.png (32.71 KiB) Viewed 441 times
stepheric
Posts: 4

Post by stepheric »

Yes, I activate my midi piano, and then I activate the lighting of the keys. The problem is after : the key I have to press lights up (this is normal), and the keyboard plays the note at the same time without my having pressed.
Bavi_H
Posts: 27

Post by Bavi_H »

In MIDI, you can change the volume of a note using "velocity" or using "volume".

It looks like when Synthesia sends a note for lighting up a key, it sends the minimum velocity. But Synthesia doesn't change the volume, it is whatever your keyboard uses by default.

On most keyboards, the minimum velocity won't be audible. But maybe the minimum velocity is audible on your keyboard?

To help experiment with velocity and volume, I made the attached HTML and JavaScript page that can send a test MIDI note.


midi-test.zip
(1.42 KiB) Downloaded 4 times

midi-test.png
midi-test.png (2.37 KiB) Viewed 404 times


How to test:

Close Synthesia, then open the attached HTML file in a browser that supports WebMIDI, like Chrome or Edge.

Send a test note with the minimum velocity. Does the key light? Does the note sound?

Send a test note with the minimum volume. Does the key light? Does the note sound?

When you are done testing, close the browser tab to ensure the browser has released all MIDI devices.


If your keyboard makes no sound using the minimum volume, then maybe we can ask the Synthesia developer to consider adding a volume change command for key lighting. (At the beginning of a song, change the volume to zero on the channel used for key lights.)


Alternative workaround: Set up Synthesia to use its built-in MIDI synthesizer, and use the sound from your computer speakers. Then set the volume on your keyboard to the minimum or plug in some headphones without actually wearing them, just to turn off your keyboard speakers.
Nicholas
Posts: 12821

Post by Nicholas »

I'd also like to hear if this works. Sending a zero-volume message to the key light channel is a great idea!
stepheric
Posts: 4

Post by stepheric »

Thank yu very much for your answer, Bavy. Very good idea. :) I can't test today, but perhaps tomorrow... I keep you posted
stepheric
Posts: 4

Post by stepheric »

I have tested with your html and javascript page. Results are very interesting.

If I send a test note with the minimum velocity but not minimum volume, the key lights and the note sounds (at the same level as with Synthesia)

If I send a test note with the minimum volume but not minimum velocity, the key lights and the note sounds (at the same level as with Synthesia)

If I send a test note with the minimum volume and minimum velocity :
- if the piano volume is not set very loud (but enough to hear my notes very well when I press the keys), the key lights and the note does not sound
- if the piano volume is louder, the key lights and the note sounds (but much less loud than when I press the keys, and much less loud than with Synthesia)
Therefore, this solution is satisfactory

If I send a test note with the maximum volume and maximum velocity, the key lights and the note sounds (much louder than with Synthesia). In this case, Final Volume = volume + velocity !

After the test with the minimum volume and minimum velocity , I closed Google Chrome and I tried with Synthesia again. And then, if the piano volume is not set very loud (but enough to hear my notes very well when I press the keys), the key lights and the note does not sound, exactly like when i was using html and javascript page on Google Chrome ! So your html and javascipt page can be seen as a solution to my problem if I use it before I run Synthesia ! Even if, of course, it would be better if we could choose this setting directly in Synthesia.

So, thank you Bavi !
Nicholas
Posts: 12821

Post by Nicholas »

That's great news that this workaround seems to be an effective one.

I only have two reservations about enabling a "send a Channel Volume 0 message to the key light channel" feature by default:

1. The case where you're interested in playing a song in Synthesia with >=16 parts. Synthesia does its best to "reserve" the key light channel for its own purposes by shimmying any notes from the song to different channels. But when the song has too many tracks/instruments to "clear out" one of the channels, it just sort of throws its hands up in the air and lets song notes coexist on the same channel (leading to too many key lights being shown). With minimum channel volume, that part would also go silent.

2. When the key light channel also happens to be the default playback channel on the digital piano. This will be true for most Yamaha keyboards where they use channel 1 input for key lights but also play local input through channel 1. With minimum channel volume, this would behave like "Local Off", which wouldn't be ideal.

That said, it's fairly trivial to implement but it feels safest to leave disabled by default.
Post Reply