Scores go up then revert as if never gained

Trouble with Synthesia, your keyboard, or adapter? Think you found a bug?
When describing problems, always mention your OS and game version (shown at the bottom of the title screen).
  • If your keyboard has USB or MIDI ports, there is a tremendously high chance (>99%) it will work with Synthesia. See what you'll need on the keyboards page.
  • If you have a Logitech webcam and can't get your keyboard/adapter to work, see this post.
Post Reply
jonpaul
Posts: 4

Post by jonpaul »

We get scores, but now we go back the next day and they are gone as if no progress was made. We've played Synthesia for years now. The tablet version had issues. I noticed the PC was far more stable. This issue is occurring on the PC though.

So for instance. My son has a yellow on both hands rhythm... Gets green. Goes over to Recital to start work. Plays a bit then leaves. He returns to the program to find that he's back at having yellow on both hands rhythm.

Please help.
Nicholas
Posts: 12644

Post by Nicholas »

How strange. It sounds like Synthesia isn't able to write its data files anymore for whatever reason (but is still able to open the previous copy from the last time data was successfully saved).

Do you remember if any major system events happened around the same time the problem showed up? Restoring from a backup or System Restore Point can sometimes mess with the permissions on data folders.
jonpaul
Posts: 4

Post by jonpaul »

Hi Nicholas thanks for your help.

No I don't know of any system event that took place... You know Microsoft updates the OS like every hour...lol. I don't know what may have happened.

I think I read in a post around here that there's a score file. Do you think there's a way I can save their scores, uninstall, reinstall and copy the score file back over to the directory?

By the way, we purchased your software. Just so you know, we really support Synthesia. Come to think of it I don't even know if there's a free version or if it's just a trial period or something... Anyway, just letting you know we support you and thanks!
Nicholas
Posts: 12644

Post by Nicholas »

Hmm, you could try saving the data files someplace else, wiping out the folder, letting Synthesia create everything fresh, and then copy the original files back in to see if that helps.

Here's how you'd do something like that:
  1. Hold your Shift key while launching Synthesia to show the configuration window.
  2. Click the "Open Data Folder" button to show the folder in Windows Explorer.
  3. (Close the configuration window.)
  4. Copy the dozen or two files in that folder someplace safe (say, to a folder on your desktop).
  5. Go "up" a level (to the "Roaming" folder).
  6. Delete or rename the Synthesia folder in Roaming.
  7. Start Synthesia normally. It should appear like a totally fresh installation with everything completely reset.
  8. Try playing a song, quitting, and restarting the app to see if the recent songs list, progress tracking, and other data shows up for that performance.
  9. Quit the app and repeat steps #1, #2, and #3 to get back to the data folder (with the configuration window closed).
  10. Copy your original files back in.
  11. Repeat the step #8 experiment to see if that worked.
jonpaul
Posts: 4

Post by jonpaul »

Nick

I've followed your instructions. We'll try it this week and I'll report back. Thanks!
jonpaul
Posts: 4

Post by jonpaul »

Nick

Things are looking good again. I think that solved the issue. Much thanks for that and SYNTHESIA!
Nicholas
Posts: 12644

Post by Nicholas »

Thanks for the follow-up. I'm actually surprised that was able to help. I've given the advice maybe one or two other times but never heard back, so I never knew for sure. How strange. It can be frustrating how fickle computers are.

In any event, please let me know if you run into any other trouble. Thanks!
Post Reply