8.6 Preview r2347 - Metadata features and some extras

Archived development update discussion from past versions
Archived development updates.
TonE
Synthesia Donor
Posts: 1180

Post by TonE »

Van Basco's Karaoke Player offers different 'reset types' in its settings, GM reset, GS reset, XG reset. It would be great if Synthesia could offer a similar thing. Otherwise it can happen with certain midi files some instruments are not heard/played in Synthesia as the reset type is not correct.

Example: Drums are not heards inside Synthesia, but inside Van Basco's Karaoke Player they play well.

I would make GS reset default, as quite a lot of midi files use this, and XG plays with GS anyway most times. So much more midi files would work correctly inside Synthesia by default.
Nicholas
Posts: 12471

Post by Nicholas »

You can tell Synthesia to send one (or more :? ) of the three different SysEx reset messages (GM, GS, or XG) by enabling any of the "Midi.Reset.Reset*" settings in the config tool. It will send one of those each time it resets the device (between songs, etc.)
TonE
Synthesia Donor
Posts: 1180

Post by TonE »

Ok, great, just set GSReset to ON, but still 'my problem' did not disappear, the drums still can not be heard inside Synthesia, where it should. I suppose the reason is the midi file is using ROOM drum kit and Synthesia does not allow changing percussion. If it does not change anything also internally, maybe this is the reason why drums do not play then?

I just added a test song you can check with.
test-song.zip
(3.39 KiB) Downloaded 181 times
Nicholas
Posts: 12471

Post by Nicholas »

I'm pretty sure the extended GS drum sets should be working fine. I just tried that file in Windows Media Player and Synthesia and they both sounded the same. Which output device are you using where percussion isn't working? Do you mean there is no percussion at all?
TonE
Synthesia Donor
Posts: 1180

Post by TonE »

Ok, sorry, found the reason: In my settings 'Percussion' was set to Off, I never did this I think, so I had to switch it to on. Now they play as they should, great. :) Sorry for the confusion.
kiwi
Synthesia Donor
Posts: 1178

Post by kiwi »

Yep strange seems many don't hit this option and haven't the percus enabled (personnally i haven't this problem).
Locked